Sincronizar iPod Classic y Nano

De doc.ubuntu-es
(Diferencias entre revisiones)
Saltar a: navegación, buscar
(creo página)
 
m (corrijo sintaxis)
 
(No se muestran 3 ediciones intermedias realizadas por 2 usuarios)
Línea 1: Línea 1:
== Ubuntu 7.10 ==
+
Las aplicaciones con las que puedes sincronizar el iPod bajo Ubuntu, como [[Amarok]], [[Rhythmbox]], [[Banshee]], [[gtkpod]] o [[Songbird]] utilizar esta biblioteca '''libgpod'''.
Las aplicaciones con las que puedes sincronizar el iPod bajo Ubuntu, como [[Amarok]], Rhythmbox, Banshee, gtkpod o [[Songbird]] utilizar esta biblioteca libgpod.
+
  
Con el nuevo iPod Classic (6ª generación) vídeo y nano (3ª generación), sin embargo, el Ipod verifica que la información en la base de datos haya sido guardada desde iTunes usando un checksum y si no es así, el iPod no mostrará ninguno de los títulos transferidos, música, vídeos o fotografías.
+
Con el nuevo iPod Classic (6ª generación) vídeo y nano (3ª generación), sin embargo, el iPod verifica que la información en la base de datos haya sido guardada desde iTunes usando un checksum y si no es así, el iPod no mostrará ninguno de los títulos transferidos, música, vídeos o fotografías.
  
La última versión de la librería libgpod soluciona el tema de la protección checksum en Ipods de última generación. Sin embargo, esta versión (0.6.0 o superior) no está aún en los repositorios oficiales de Ubuntu, y debe ser instalado manualmente.
+
La última versión de la biblioteca libgpod soluciona el tema de la protección checksum en iPods de última generación. Sin embargo, esta versión (0.6.0 o superior) no está aún en los repositorios oficiales de Ubuntu, y debe ser instalado manualmente.
  
 
== Instalación ==
 
== Instalación ==
  
Lo primero que se necesita es instalar unos cuantos paquetes necesarios para el manejo del Ipod, para esto utiliza aptitude desde la consola:
+
Lo primero que se necesita es [[instalar aplicaciones|instalar]] los paquetes <code>build-essential</code>, <code>libgpod2</code>, <code>libglib2.0-dev</code>, <code>libgtk2.0-dev</code>, <code>libsgutils1-dev</code>, <code>checkinstall</code> y <code>gettext</code>.
  
sudo apt-get install build-essential libgpod2 libglib2.0-dev libgtk2.0-dev libsgutils1-dev checkinstall gettext
+
Una vez hecho esto vamos a descargarnos el código fuente del libgpod-(>=0.6.0).tar.gz para editarlo y de esta manera hacer que el script ipod-read-sysinfo-extended funcione (este script modifica el checksum para poder así sincronizar el iPod).
  
Una vez hecho esto vamos a descargarnos el código fuente del libgpod-(>=0.6.0).tar.gz para editarlo y de esta manera hacer que el script ipod-read-sysinfo-extended funcione (Este script modifica el checksum para poder así sincronizar el Ipod).
+
Para descargar el libgpod debemos entrar [http://ufpr.dl.sourceforge.net/sourceforge/gtkpod/libgpod-0.6.0.tar.gz aquí]. Una vez que tengamos el archivo guardalo en un lugar donde tengas permisos, extraelo y dirígete a la carpeta en la que se encuentra para compilarlo:
 
+
Para descargar el libgpod debemos entrar [http://ufpr.dl.sourceforge.net/sourceforge/gtkpod/libgpod-0.6.0.tar.gz aquí}. Una vez que tengamos el archivo guardalo en un lugar donde tengas permisos, extraelo y dirígete a la carpeta en la que se encuentra para compilarlo:
+
  
 
Extrae el paquete:
 
Extrae el paquete:
Línea 21: Línea 18:
 
  cd /ruta/libgpod-0.6.0
 
  cd /ruta/libgpod-0.6.0
 
Compila el código fuente:
 
Compila el código fuente:
./configure && make
+
./configure && make
  
 
Una vez hecho esto hay que editarlo:
 
Una vez hecho esto hay que editarlo:
Línea 84: Línea 81:
 
  ipod-read-sysinfo-extended /dev/sda /media/IPOD
 
  ipod-read-sysinfo-extended /dev/sda /media/IPOD
  
Si has seguido todos los pasos de la manera que esta explicada no debería haber ningún error y podrás utilizar el Ipod.
+
Si has seguido todos los pasos de la manera que esta explicada no debería haber ningún error y podrás utilizar el iPod.
  
 
== Trucos ==
 
== Trucos ==
; En amarok
+
 
Para sincronizar las portadas, cuando conectes el iPod, en la parte superior de amarok aparece un iPod, dale click ahí, elijes '''Update Artwork''' y espera que sincronice todo el contenido.
+
; En Amarok
 +
: Para sincronizar las portadas, cuando conectes el iPod, en la parte superior de amarok aparece un iPod, dale click ahí, eliges '''Update Artwork''' y espera que sincronice todo el contenido.
  
 
== Fuentes ==
 
== Fuentes ==
* [http://www.ubuntu-es.org/index.php?q=node/71388 Sincronizar Ipod Classic / Nano Video en Ubuntu Gusty Gibbon]] en http://ubunru-es.org
+
 
* [http://wiki.ubuntuusers.de/iPod/Classic_und_Nano_Video Ipod Classic y Nano video] ''en alemán''
+
* [http://www.ubuntu-es.org/index.php?q=node/71388 Sincronizar Ipod Classic / Nano Video en Ubuntu Gusty Gibbon] en [http://www.ubuntu-es.org/ ubuntu-es.org].
 +
* [http://wiki.ubuntuusers.de/iPod/Classic_und_Nano_Video iPod Classic y Nano video] {{de}}.
 +
 
 +
[[Categoría:Multimedia]]
 +
[[Categoría:Dispositivos portátiles]]

Última revisión de 02:19 14 jun 2008

Las aplicaciones con las que puedes sincronizar el iPod bajo Ubuntu, como Amarok, Rhythmbox, Banshee, gtkpod o Songbird utilizar esta biblioteca libgpod.

Con el nuevo iPod Classic (6ª generación) vídeo y nano (3ª generación), sin embargo, el iPod verifica que la información en la base de datos haya sido guardada desde iTunes usando un checksum y si no es así, el iPod no mostrará ninguno de los títulos transferidos, música, vídeos o fotografías.

La última versión de la biblioteca libgpod soluciona el tema de la protección checksum en iPods de última generación. Sin embargo, esta versión (0.6.0 o superior) no está aún en los repositorios oficiales de Ubuntu, y debe ser instalado manualmente.

[editar] Instalación

Lo primero que se necesita es instalar los paquetes build-essential, libgpod2, libglib2.0-dev, libgtk2.0-dev, libsgutils1-dev, checkinstall y gettext.

Una vez hecho esto vamos a descargarnos el código fuente del libgpod-(>=0.6.0).tar.gz para editarlo y de esta manera hacer que el script ipod-read-sysinfo-extended funcione (este script modifica el checksum para poder así sincronizar el iPod).

Para descargar el libgpod debemos entrar aquí. Una vez que tengamos el archivo guardalo en un lugar donde tengas permisos, extraelo y dirígete a la carpeta en la que se encuentra para compilarlo:

Extrae el paquete:

tar -xvzf libgpod-0.6.0.tar.gz

Entra en el directorio creado:

cd /ruta/libgpod-0.6.0

Compila el código fuente:

./configure && make

Una vez hecho esto hay que editarlo: Ejecuta:

sudo checkinstall

Si el programa pide la creación de un directorio teclea [y] y le dale a enter, luego le dale de nuevo a enter dejando una linea en blanco. A continuación aparecerá en la consola algo similar a esto:

0 - Maintainer: [ root@usuario ]
1 - Summary: [ ]
2 - Name: [ libgpod ]
3 - Version: [ 0.6.0 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ i386 ]
8 - Source location: [ libgpod-0.6.0 ]
9 - Alternate source location: [ ]
10 - Requires: [ ]

Te pedirá que ingreses el numero de la opción a modificar, así que ingresa 2 y luego libgpod2 de modo que te quede así:

0 - Maintainer: [ root@usuario ]
1 - Summary: [ ]
2 - Name: [ libgpod2 ]
3 - Version: [ 0.6.0 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ i386 ]
8 - Source location: [ libgpod-0.6.0 ]
9 - Alternate source location: [ ]
10 - Requires: [ ]

Para finalizar le dale a enter y aparecerá un mensaje de paquete se ha instalado con éxito.

Por último vamos a crear un par de enlaces que nos permitan usar la versión 2, así que introduce lo siguiente en la consola:

sudo ln -fs /usr/local/lib/libgpod.so.3 /usr/lib/libgpod.so.2
sudo ln -s /usr/local/lib/libgpod.so.3 /usr/lib/libgpod.so.3

Ahora tienes que darle al script ipod-read-sysinfo-extended la dirección donde esta montado el Ipod para que pueda arreglar el checksum. Para ello introduce en la consola la siguiente orden para saber dónde está:

blkid

Esto te devolverá algo así:

..
/dev/sda1: LABEL="IPOD" UUID="XXXX-XXXX" TYPE="vfat;

Lo que quiere decir que el Ipod esta en /dev/sda, Usando esto monta el Ipod:

mount | grep /dev/sda1

De modo que obtendrás algo así:

/dev/sda1 on /media/IPOD type vfat (rw,nosuid,nodev,noatime,flush,uid=1000,utf8,shortname=lower)

Y finalmente utiliza el script de la siguiente manera:

ipod-read-sysinfo-extended /dev/sda /media/IPOD

Si has seguido todos los pasos de la manera que esta explicada no debería haber ningún error y podrás utilizar el iPod.

[editar] Trucos

En Amarok
Para sincronizar las portadas, cuando conectes el iPod, en la parte superior de amarok aparece un iPod, dale click ahí, eliges Update Artwork y espera que sincronice todo el contenido.

[editar] Fuentes

Herramientas personales